1911 Firearm Addicts banner

1 - 5 of 5 Posts

·
Banned
Joined
·
824 Posts
Discussion Starter #1
So the other day I took down my Winchester 97 to refinish it. I was only refinishing the barrel, mag tube, and receiver for now, so i didn't disassemble the bolt and carrier, just removed them. When I put it back together, the hammer wouldn't lock back at all unless the gun was held upside down. Now the hammer will lock back maybe 3/5 times, but it seems to just barely be locking and the trigger is dangerously light now.

The issue appears to be related to the sear spring, as when I apply pressure to it, the hammer locks back nice and solid. I did notice that the end of the spring that applies pressure to the sear is raised, but I thought it used to be flush with the bottom of the carrier, am I wrong? I see no visible damage, so I'm wondering if something is just out of place, or if I need to replace the spring.
 

·
Registered
Joined
·
374 Posts
I'm sure you know this already. If it was working when you took it apart and now it doesn't.... Take it back apart and use youtube or and assembly manual to reassemble. There is most likely one little trick that you forgot about.

...Ron
 

·
Banned
Joined
·
824 Posts
Discussion Starter #3
I'm sure you know this already. If it was working when you took it apart and now it doesn't.... Take it back apart and use youtube or and assembly manual to reassemble. There is most likely one little trick that you forgot about.

...Ron
Haha, already done a few times now. My current issue is I can't tell if my sear spring is just worn, or if something is out of place. A pic of the bottom of the carrier would help me determine that, but such photos seem to be rare. Thanks for the reply though.
 
1 - 5 of 5 Posts
Top