Marauder with a X300u-a... HELP!!!

Discussion in 'STI/2011' started by firecatwilson, Jan 17, 2019.

  1. firecatwilson

    firecatwilson Well-Known Member

    595
    Feb 24, 2013
    I've been trying to find more info/pics on how I can make my Surefire X300u-a work on my Marauder. I've seen a few pictures that guys have mounted them, and I've tried all the mounting options but can't seem to make it work. Anyone here with a Marauder and a X300u-a or b?

    Is there another way to mount the light without having to file down the serrations/stippling on the front of the grip?

    Read another guy filed down the "universal" rail attachment on the light itself, but wasn't clear if it was with the quick attach or rail lock.

    Any help would be great, trying to set this thing up for my HD/Bedside gun.

    Thanks!!
     
  2. firecatwilson

    firecatwilson Well-Known Member

    595
    Feb 24, 2013
    ChuckC helped me out. I'll document the info in case anyone else runs into this issue.

    On the back of the battery door, there are 4 pins that hold a spacer, simply drive them out with a punch and wala... it fits without issue.

    I haven't seen/read anyone else say they did this to fit the X300u's. They all filed down the trigger guard or modified the picatinny rail on the light. I'm glad I didn't have to do any of that.
     

  3. token3495

    token3495 New Member

    4
    Jan 17, 2019
    That’s interesting. Is this specific to mauraders or any 2011 with a rail? I run a x300u-a on both my tactical and Omni and they both butt up against the trigger guard. I just had to loosen the two side rails to get it on then tightened it down once in place.

    Instructions would be really helpful if I run into this in the future
     
  4. firecatwilson

    firecatwilson Well-Known Member

    595
    Feb 24, 2013
    I've heard the guys with Marauders and the Costa (VIP's I believe) have this issue, since they both have a shorter half rail. I tried about everything, minus filing my trigger guard and taking this spacer off the battery door. I couldn't even get it to set in place and try to screw the rails in after, was an easy 1/8-1/4 in. off, ahead of the 1st picatinny rail.

    Works great for me now, I have it in the rail lock setup with the "P" rail lock.

    Almost sounds like yours was a little too narrow?? Is that why you put the rails on after? Rail on pistol was too tight, width-wise? I've heard of that problem also, but that was not my problem here.

    Here is the pic of the short 4 pins to drive out.
    STI Pins.jpg

    Then remove this back spacer.
    X300.jpg
    View attachment 203365
     
    Last edited: Jan 18, 2019
  5. token3495

    token3495 New Member

    4
    Jan 17, 2019
    The rail on the pistol was a tad bit wider than the x300 slots from the factory. I loosened the light rails a little to give a little more room to fit over the picatinny rail. Once on, I retightened them for a solid fit
     
    firecatwilson likes this.
  6. firecatwilson

    firecatwilson Well-Known Member

    595
    Feb 24, 2013
    Yeah the problem with these are the rail slot to trigger guard length, or lack there of.
     
  7. Nemain

    Nemain Well-Known Member

    811
    Feb 3, 2016
    A bit off subject but for what it’s worth, I quit using Surefire pistol lights and went to Streamlight TLR 1 HL lights. Surefires quality is garbage anymore and their customer service is terrible. I have personally found Streamlight TLR 1 HL to be a simpler operation and a much better fit.
     
  8. Descartian

    Descartian Well-Known Member

    Apr 13, 2017
    I am a streamlight fan as well.
     
    FWoo45 and Nemain like this.
  9. firecatwilson

    firecatwilson Well-Known Member

    595
    Feb 24, 2013