Problem Solved with New Build

Discussion in '1911 Gunsmithing' started by paid4c4, Jan 19, 2012.

  1. paid4c4

    paid4c4 Supporting Addict Supporting Addict

    303
    Sep 26, 2011
    As I posted earlier I had a problem with a new build;http://www.1911addicts.com/showthread.php?2744-Help-with-Grip-Safety

    Which turned into another problem which I believe to be an inadequate match between the hammer hooks and the sear. I decided to go with Nowlin's Speed Demon Ignition Set, which has been pre fitted. http://www.nowlinguns.com/product-info.php?Nowlin_Gun_Manufacturer_Small_Gun_Parts-pid195.html

    I ordered the kit from Midway which was $135 and came in two days. I spoke with CS at Nowlin and they recommended a BTGS from STI to accompany their Speed Demon kit. Well between the kit and the STI BTGS I have one smooth first build. I'm guessing the trigger pull to be about 4 lbs as installed without tweaking any of the supplied parts. I'll test fire it tomorrow or Saturday and post the outcome with pictures. I think I could have fixed the problem using the old parts if I had a sear jig and some stones. I'm going to try to use the parts in my next build just to see if I can figure things out.
    Bill
     
  2. knedrgr

    knedrgr Low capacity, low tech...

    Aug 15, 2011
    pictures of your build?
     

  3. Bender

    Bender Supporting Addict Supporting Addict

    Aug 15, 2011
    Cool,....pics when you can
     
  4. paid4c4

    paid4c4 Supporting Addict Supporting Addict

    303
    Sep 26, 2011
    I'm going to shoot it hopefully tomorrow I'll then post pictures of the target and the pistol. Which will be the before pictures as the pistol goes next for engraving and Cerecoating.
    Bill
     

You need 3 posts to add links to your posts! This is used to prevent spam.

Verification:
Draft saved Draft deleted